9 min read

Introduction

Une partie importante de la création des modèles a lieu dans la fenêtre de travail. Toutes les fonctions peuvent être appelées avec les menus. Les fonctions les plus fréquemment utilisées sont également accessibles via la barre d'outils (la zone sous le menu) et via des raccourcis clavier.

Important : les constructeurs délaissent la construction des modèles dans Home-Nostruktor au profit des logiciels 3D gratuits comme Blender plus intuitif et facile d'utilisation. Néanmoins les fonctions pour la création des modèles dans Home-Nostruktor seront tout de même présentées.

Les menus, la barre d'outils et les raccourcis clavier sont décrits ci-après. Lorsqu'une commande ouvre une nouvelle fenêtre de dialogue, celle-ci est décrite dans un sous-article à part.

Les menus

Nouveau

Raccourci clavier : Ctrl + N
Crée un nouveau fichier de construction *.kon pour l'objet en cours.

Ouvrir

Raccourci clavier : Ctrl + O
Affiche une boîte de dialogue pour sélectionner un fichier de construction *.kon et l'ouvre pour l'objet en cours.

Fermer

Ferme le fichier de construction *.kon actif.

Enregistrer

Racourci clavier : Ctrl + S
Enregistre le fichier *.kon actif.

Enregistrer sous

Ouvre une boîte de dialogue pour enregistrer le fichier *.kon actif sous un nouveau nom. Le fichier courant change alors de nom.

Nouveau projet

Ouvre la boîte de dialogue Créer un nouveau projet ou Ajouter un nouvel objet. Avant de passer au nouveau projet, il vous sera demandé, le cas échéant, si vous voulez sauvegarder le projet en cours.

Ouvrir un projet

Ouvre une boîte de dialogue pour sélectionner un fichier projet *.prj. Avant de passer à l'autre projet, il vous sera demandé si vous voulez sauvegarder le projet en cours, le cas échéant.

Enregistrer un projet

Enregistre les modifications du projet en cours dans un fichier projet *.prj.
Attention : d'autres modifications, telles que les fichiers *.kon ou les paramètres de l'objet, sont sauvegardées automatiquement. Renoncer à l'enregistrement du projet ne signifie pas un retour complet à un état de projet antérieur.

Ouvrir le dernier projet

Ouvre le dernier projet sur lequel vous avez travaillé.

Imprimer…

Racourci clavier : Ctrl + P
Imprime le fichier de construction *.kon actif.

Aperçu

Affiche un aperçu de la page telle qu'elle sera imprimée et offre la possibilité de modifier certains paramètres.

Configuration de l'impression…

Affiche une boîte de dialogue pour modifier les paramètres d'impression (fonctionnalité Windows standard).

Paramètres du projet

Ouvre la boîte de dialogue des paramètres du projet.

Création d'un script d'installation (fichier ini)

Ouvre la boîte de dialogue Créer un script d'installation pour générer un script d'installation.

Créer l'installation du modèle (fichier eep)

Ouvre la boîte de dialogue Créer un fichier/script d'installation 3DM pour EEP pour générer une installation complète du modèle à partir des scripts d'installation créés précédemment.

Quitter

Raccourci clavier : Alt + F4
Quitte l'application et vérifie si le fichier de projet doit être sauvegardé ou pas.
Important : Si vous êtes invité à sauvegarder, alors il n'y a aucune possibilité de revenir en arrière !

Annuler

Raccourci clavier : Ctrl + Z
Annule la dernière action.

Rétablir

Raccourci clavier : Ctrl + U
Restaure l'action précédemment annulée

Effacer toutes les valeurs de couleurs pour l'éclairage

Cette commande permet d'effacer toutes les valeurs de couleurs pour l'éclairage définies dans la fenêtre de dialogue Propriétés du sommet. De plus, les fonctions d'éclairages spécifiques seront toutes réinitialisées sur 'Lumières éteintes'. Un message vous demandera de confirmer la réinitialisation.

Toutes les textures réinitialisées à 0

Réinitialise l'assignation de tous les ID et coordonnées des textures de tous les sommets. Un message vous demandera de confirmer la réinitialisation.

Couper

Raccourci clavier : Ctrl + X
Efface la sélection et la transfère dans le presse-papier.

Copier

Raccourci clavier : Ctrl + C
Copie la sélection et la transfère dans le presse-papier.

Coller

Raccourci clavier : Ctrl + V
Insère le contenu du presse-papier.

Marquage

Marque une partie du document à découper, copier, effacer ou manipuler.

Supprimer

Supprime le contenu de la zone marquée.

Outils de dessin / Vertex/Sommet

Raccourci clavier : Shift + P
Dessine des Vertex/Sommets.

Outils de dessin / Ligne de découpe

Raccourci clavier : Shift + L
Ligne de bordure et découpe pour exclure certaines parties d'une figure géométrique.

Outils de dessin / Ligne de connexion/subdivision

Raccourci clavier : Shift + S
Ligne de connexion/subdivision.

Outils de dessin / Rectangle

Raccourci clavier : Shift + B
Dessine un rectangle avec une ligne pointillée.

Outils de dessin / Ellipse

Raccourci clavier : Shift + E
Dessine une ellipse.

Echelle / Augmenter

Raccourci clavier : Page haut
Augmente le zoom d'un niveau.

Echelle / Réduire

Raccourci clavier : Page bas
Réduit le zoom d'un niveau.

Règle / Afficher ou masquer

Raccourci clavier : Shift + G
Affiche ou masque la règle.

Règle / Alterner la graduation

Raccourci clavier : Shift + J
Alterne la graduation de la règle aux axes de coordonnées (au-dessus ou au-dessous).

Gomme

Raccourci clavier : Shift + O
Active la gomme.

Gestion des instances

Raccourci clavier : Shift + K
Ouvre la fenêtre de dialogue Gestion des instances pour copier ou modifier des instances.

Propriétés des sommets

Raccourci clavier : Shift + T
Sélectionne un sommet et ouvre la fenêtre de dialogue Propriétés du sommet.

Capturer/Déplacer un sommet

Raccourci clavier : Shift + R
Capture et déplace un sommet préalablement sélectionné.

Raccorder les lignes

Raccourci clavier : Shift + M
Raccorde les extrémités des lignes et fixe les sommets.

xxxxxxxxxxxxxxx

Raccourci clavier : Shift + A
xxxxxxxxxxxxxxxxxxxxx.

Afficher/masquer la visionneuse 3D

Raccourci clavier : Shift + I
Affiche ou masque la construction (fichier *.kon) active dans la visionneuse 3D.

Transférer la couleur non éclairée

Raccourci clavier : Shift + F
Transfère la valeur de couleur non éclairée du dernier sommet édité vers d'autres sommets.

Transférer la hauteur Z

Raccourci clavier : Shift + H
Transfère la valeur de hauteur (Z) du dernier sommet édité vers d'autres sommets.

Transférer la couleur éclairée

Transfère les valeurs des couleurs pour l'éclairage du dernier sommet édité vers d'autres sommets.

Transférer les valeurs du sommet

Transfère les valeurs des couleurs pour l'éclairage, réflexion/émissions et spéculaire du dernier sommet édité vers d'autres sommets.

Ajouter une nouvelle texture

Ajoute une nouvelle texture.

Importer un objet

Importe un autre fichier mod2, obj, x ou n3d dans l'objet courant.

Enregistrer l'objet

Enregistre le fichier obj dans le dossier de l'objet courant. Cependant, vous pouvez également spécifier un nom de fichier différent et/ou un dossier différent.

Créer un nouvel objet

Crée un nouvel objet pour le modèle. La boîte de dialogue Créer un nouveau projet ou Ajouter un nouvel objet va s'afficher.

Nouveau niveau LOD

Crée un objet mais en tant que nouveau niveau LOD. Le nouveau nom est dérivé du nom de l'objet courant en ajoutant _LOD1 ou en incrémentant le niveau LOD d'une unité par rapport au précédent. La case à cocher pour la duplication est activée et les autres réglages de l'objet sont pris en compte.

Supprimer l'objet

Après une demande de confirmation, l'élément en cours d'édition est supprimé, y compris le dossier, les sous-dossiers et les fichiers *.kon qui lui sont associés.

Paramètres de l'objet

Ouvre la boîte de dialogue des Paramètres des instances.

Points de référence

Ouvre la boîte de dialogue de définition des points de référence. Les points de référence ne jouent un rôle que pour les objets de voie ou spline (voir Construction des objets de voie).

Importer le fichier GSB/Def en tant que projet

Réutilise un modèle (jusqu'à la version EEP6) pour créer un nouveau projet. Pour mener à bien l'opération, les composants du modèle doivent se trouver à l'endroit approprié dans l'arborescence des dossiers du programme Home-Nostruktor. Le projet peut ensuite être traité à partir d' EEP7 ou versions ultérieures.

Ordre des axes

Ouvre la fenêtre d'imbrication des axes.

Paramètres globaux du modèle (Fichiers INI)

Ouvre la boîte de dialogue pour l'édition des fichiers INI externes et interne du modèle.

Exportation du modèle au format 3DM

Ouvre la boîte de dialogue Exportation du modèle au format *.3dm pour créer un fichier *.3dm au format EEP.

Barre d'outils

Affiche ou masque la barre d'outils.

Barre de statut

Affiche ou masque la barre de statut.

Changer l'arrière-plan

Permet de changer l'arrière-plan par défaut dans la fenêtre de travail en sélectionnant un autre fichier au format bmp dans la fenêtre affichée à cet effet.

Nouvelle fenêtre

Créer une copie (clone) du dernier fichier *.kon ouvert.

En cascade

Réordonne en cascade les fenêtres des fichiers *.kon ouverts.

Côte-à-côte

Réordonne côte-à-côte les fenêtres des fichiers *.kon ouverts.

Arranger

Arrange côte-à-côte les fenêtres des fichiers *.kon ouverts. (Si pas visibles).

Liste des fichiers ouverts

Affiche la liste des fichiers *.kon. Cette liste peut varier en fonction du nombre de fichiers ouverts.

Aide

Cette commande est obsolète et ne doit plus être utilisée. Pour trouver une aide actualisée. Veuillez consulter le wiki à cette adresse :
https://wiki.eepshopping.de/index.php?title=Hauptseite_EEP_Wiki&redirect=no

A propos de HOME- Nostruktor

Affiche les mentions légales.

La barre d'outils

Image menu Fichier Nostructor

Raccourci clavier : Ctrl + N
Crée un nouveau fichier de construction *.kon pour l'objet en cours.

Image menu Fichier Nostructor

Raccourci clavier : Ctrl + O
Affiche une boîte de dialogue pour sélectionner un fichier de construction *.kon et l'ouvre pour l'objet en cours.

Image menu Fichier Nostructor

Raccourci clavier : Ctrl + S
Enregistre le fichier *.kon actif.

Icône liste objets EEP Nostruktor

Liste des objets pour l'édition.

Icône nouvel objet EEP Nostruktor

Crée un nouvel objet pour le modèle. La boîte de dialogue Créer un nouveau projet ou Ajouter un nouvel objet va s'afficher. Si vous cliquez sur le bouton et maintenez simultanément la touche [Shift] appuyée, vous allez créer un objet mais en tant que nouveau niveau LOD. Le nom de l'objet est dérivé du nom de l'objet courant en ajoutant _LOD1 ou en incrémentant le niveau LOD d'une unité. La case à cocher pour la duplication est activée et les autres réglages de l'objet sont pris en compte.

Icône supprimer l'objet EEP Nostruktor

Après une demande de confirmation, l'élément en cours d'édition est supprimé, y compris le dossier, les sous-dossiers et les fichiers *.kon qui lui sont associés.

Icône nouveau projet pertinent EEP Nostruktor

Ouvre la boîte de dialogue Créer un nouveau projet ou Ajouter un nouvel objet, mais seules les zones pertinentes pour le rendu peuvent être modifiées.

Icône objet modèle EEP Nostruktor

Permet de basculer entre la représentation de l'objet courant et le modèle complet dans la Visionneuse 3D.

Image menu Fichier Nostructor

Ouvre la boîte de dialogue des paramètres du projet.

Icône paramètres ini EEP Nostruktor

Ouvre la boîte de dialogue pour l'édition des fichiers INI externes et interne du modèle.

Icône paramètres de l'objet EEP Nostruktor

Ouvre la boîte de dialogue des Paramètres des instances.

Icône ordre axes EEP Nostruktor

Ouvre la boite de dialogue d'imbrication des axes.

Icône déplace axe EEP Nostruktor

Masque la fenêtre de travail et affiche la fenêtre Déplacer les axes, qui vous permet de déplacer un axe sélectionné pour le visualiser dans la Visionneuse 3D.

Icône exportation modèle 3DM EEP Nostruktor

Ouvre la boîte de dialogue Exportation du modèle au format *.3dm pour créer un fichier *.3dm au format EEP.

Icône Aide EEP Nostruktor

Cette commande est obsolète et ne doit plus être utilisée. Pour trouver une aide actualisée. Veuillez consulter le wiki à cette adresse :
https://wiki.eepshopping.de/index.php?title=Hauptseite_EEP_Wiki&re

0 0 votes
Évaluation de l'article
S’abonner
Notification pour
guest
0 Commentaires
Commentaires en ligne
Afficher tous les commentaires
Retour en haut